Have fun !!!
This puzzle works with Internet Explorer 4.0 or higher and Netscape 4.7, but unfortunately not with Netscape 7.0.